my-cumbria-logo, Toggle navigation

Office 365 - for home, for free!

Microsoft’s Student Advantage gives students and staff the ability to install Office on up to 5 personally owned (not university issued) PCs and Macs.

Office 365 Professional Plus is provided on a subscription basis - you can use the latest version of Office while you are registered with the university and have an active network login account.

How do I install Office 365 Professional Plus?

Office Professional Plus is provided as a download. You will require a good internet connection and will need to stay on-line until it is installed.

Sign in to Office365

  • Open the Microsoft Log in page - please bookmark https://outlook.com/uni.cumbria.ac.uk on your devices
  • In the Office365 ID box, type your email address. Enter it as s123456@uni.cumbria.ac.uk (student) or first.last@cumbria.ac.uk (staff)
  • In the Password box, type your Network password.

Installing the software

  • Once you have logged in to your email, click on the small circle in the top right corner (it might have your picture on it)  and select My Account
  • You may now be asked to log in again
  • In the main window you will see an Install Office button, click that and follow the on screen instructions

FAQs

  • Some frequently asked questions have been posted and answered - see the FAQs tab above.

FAQs

What happens when I leave?

The software is deactivated when your user account is removed after you leave the university. If you wish to continue to use the software you can purchase a subscription.

I have a previous version of Office - can I keep this?

Office 365 Professional Plus will install alongside your current Office installation.

What happens if I have problems installing the software?

This offer is from Microsoft, not from the university.  As a result if you have any problems installing the software on your device, you will need to contact Microsoft for support.

Does it work on all devices?

No, it doesn't work on windows PCs running XP or older, and it wont work on Macs running older than Snow Leopard.  Please click here for the full compatibility list

Edit page